zhangqiao@ruiji Publish time 2024-4-26 15:27:08

How to do if open VPN fails to be established on Reyee EG?

Issue Description
The terminals can’t access the open VPN
https://community.ruijienetworks.com/data/attachment/forum/202404/26/144352yij66bip36mbb6i3.png


Device model and firmware


Device Type
Device Model
Device Version

Gateway
EG105G-P V2
ReyeeOS 2.248.0.2212

Access Point
RAP2260
ReyeeOS 2.230.0.2003

Possible Cause
1. EG can access the network or HQ EG is deployed on layer-2 NAT environment.
2. The configurations of EG in branch and HQ are inconsistent
3. The traffic of VPN ports are disabled on uplink network.
4. Download the client version by non-EG device or inport Client Config incorrectly.
Solution
1. EG can't access the network or HQ EG is deployed on layer-2 NAT environment.
(1) Please check that the HQ EG can be ping successfully by branch EG and both EGs can ping the external network IP (8.8.8.8).
https://community.ruijienetworks.com/data/attachment/forum/202404/26/150318qly8s49plld9jkm4.png


Please make sure that the ping service is enabled on HQ EG.
https://community.ruijienetworks.com/data/attachment/forum/202404/26/114552wxw6wmry9zsmeeep.png
(2) If the EGs fail to ping the external network, please check whether the WAN port configuration is meet the requirements of uplink network. For example, you can check the account and password of PPPOE are corrent or not? Whether it's need to configure VLAN TAC. Please contact ISP to check the network.
https://community.ruijienetworks.com/data/attachment/forum/202404/26/115135zio33lcetejctu7e.png
(3). If the HQ EG is deployed on Lay-2 NAT environment, map the EG IP port on the egress devices.
2. The configurations of EG in branch and HQ are inconsistent
Please note that the OpenVPN client must be downloaded by following link other OpenVPNs may incompatible
please refer to this post to check the configuration of EG in branch and HQ:OpenVPN configuration guide on Reyee EG - Router - Ruijie Community (ruijienetworks.com)
https://community.ruijienetworks.com/data/attachment/forum/202404/26/150711e87aqxx5c7snq5rn.png
3. The traffic of VPN ports are disabled on uplink network.
Draw a package on EG to check whether the EG normally sends and receives packets. If packets are sent but not received, you need to contact the ISP or check whether the uplink device disable the IPsec VPN UDP port 1194.
https://community.ruijienetworks.com/data/attachment/forum/202404/26/151138bgf1fkcfc3iaccac.png
4. Download the OpenVPN client side by non-EG device or inport Client Config incorrectly.
You can download OpenVPN client and related configuration guide in the following location. Please note that the OpenVPN client must be downloaded by following location, the OpenVPNs from other brands may incompatible.

https://community.ruijienetworks.com/data/attachment/forum/202404/26/151235i2tu2z4yz2o06s2o.png
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