Forgot password?
 Register now


MACC-Public

View: 32|Reply: 1

[MACC-BASE] MongoDB service fail after restart, but system running well

[Copy link]

Digests

Posts

0

Credits

Novice

Rank: 1

Credits
0
Post time 4 day(s) ago | Show all posts |Read mode
Hello, there,

I've just install MACC Base on our server. After running ./install.sh script, I find that MongoDB service is running well.
  1. [root@macc]# service mongod status
  2. ● mongod.service - SYSV: Mongo is a scalable, document-oriented database.
  3.    Loaded: loaded (/etc/rc.d/init.d/mongod; bad; vendor preset: disabled)
  4.    Active: inactive (dead)
  5.      Docs: man:systemd-sysv-generator(8)
Copy the Code
However, after I reboot the server, MongoDB service fail to start eventhough the system seems running as expected (can login, can do setting etc). These are the message shown on my screen.
  1. [root@macc SSL]# service mongod status
  2. ● mongod.service - SYSV: Mongo is a scalable, document-oriented database.
  3.    Loaded: loaded (/etc/rc.d/init.d/mongod; bad; vendor preset: disabled)
  4.    Active: failed (Result: exit-code) since Thu 2017-12-07 22:37:06 CST; 32min ago
  5.      Docs: man:systemd-sysv-generator(8)
  6.   Process: 1519 ExecStart=/etc/rc.d/init.d/mongod start (code=exited, status=1/FAILURE)
  7. Dec 07 22:37:06 macc-base-server systemd[1]: Starting SYSV: Mongo is a scalable, document.....
  8. Dec 07 22:37:06 macc-base-server runuser[1530]: pam_unix(runuser:session): session opened...0)
  9. Dec 07 22:37:06 macc-base-server mongod[1519]: Starting mongod: [FAILED]
  10. Dec 07 22:37:06 macc-base-server systemd[1]: mongod.service: control process exited, code...=1
  11. Dec 07 22:37:06 macc-base-server systemd[1]: Failed to start SYSV: Mongo is a scalable, d.....
  12. Dec 07 22:37:06 macc-base-server systemd[1]: Unit mongod.service entered failed state.
  13. Dec 07 22:37:06 macc-base-server systemd[1]: mongod.service failed.
  14. Hint: Some lines were ellipsized, use -l to show in full.
Copy the Code
I have tried to bring the service up by executing this but still cannot get the service to run.
  1. [root@macc SSL]# service mongod start
Copy the Code
Can anyone advice, what should I do? Thank you in advance for your suggestion.

-Lucky I. Ismail

Reply

Use magic Report

1

Digests

26

Posts

33

Credits

Novice

Rank: 1

Credits
33
Post time The day before yesterday 16:05 | Show all posts
what is youe linux system, have you downloaded the system suggested in the installation guide ?
Reply Support Not support

Use magic Report

You have to log in before you can reply Login | Register now