Forgot password?
 Register now


MACC-Public

View: 28|Reply: 3

[MACC-BASE] Setting timezone and URL to IP redirection

[Copy link]

Digests

Posts

0

Credits

Novice

Rank: 1

Credits
0
Post time 4 day(s) ago | Show all posts |Read mode
Hi, there,

I've just installed the MACC base on our server and everything seems to work as expected. I have two questions regarding of my new installation.

Question 1:
After the installation process finished (./install.sh), I found that our server timezone was changed to Asia/Shanghai (CST Beijing Time). The MACC web also shows the same timezone. I have changed my server timezone to Asia/Jakarta, but the MACC web was still Asia/Shanghai.
My question is: how to change MACC web timezone?

Question 2:
I can access the website through my server's public IP (for example http://123.456.678.888), doing login, setting and etc. I also have set my DNS A record to point to this IP, for example http://somedomain.com to point to IP 123.456.678.888. However, when I tried to access MACC website through http://somedomain.com, somehow I was redirected back to access IP (http://123.456.678.888). In other word, our MACC web is only accessible through http://123.456.678.888, but not from http://somedomain.com. This makes me unable to apply SSL certificate request, as http://123.456.678.888 is considered as invalid domain name.
Anyone can help me?

Thank you in advance for all helps and suggestions.

-Lucky I. Ismail
Reply

Use magic Report

1

Digests

26

Posts

33

Credits

Novice

Rank: 1

Credits
33
Post time 4 day(s) ago | Show all posts
About the secondary probelm :
If the SSO is enabled, and domain for access is needed. It requires to change the SSO URL to domain name on “vi /macc/install/tomcat/macc_conf/macc3/macc3_sso.properties”  or Copy to PC via SFTP.

Reply Support 1 Not support 0

Use magic Report

Digests

Posts

0

Credits

Novice

Rank: 1

Credits
0
 Author| Post time 4 day(s) ago | Show all posts
Levy replied at 2017-12-8 10:27
About the secondary probelm :
If the SSO is enabled, and domain for access is needed. It requires to ...

Hi Levy,

Thank you for your suggestion. It works. Now, accessing http://somedomain.com won't be redirected to http://some_IP_address.

However, it goes back to IP address if I access through port 8090, to access upgrade, HTTPS setting and backup. So, accessing http://somedomain.com:8090 is still redirected to http://some_IP_address:8090. Any clue?

Thank you, I really appreciate your help.

-Lucky I. Ismail
Reply Support Not support

Use magic Report

1

Digests

26

Posts

33

Credits

Novice

Rank: 1

Credits
33
Post time The day before yesterday 16:00 | Show all posts
About the first problem, I have tested locally, if you follow the guide, this circumstance won't appear, and I will show you  the way to change the timezone.

This post contains more resources

You have to Login for download or view attachment(s). No Account? Register

x
Reply Support Not support

Use magic Report

You have to log in before you can reply Login | Register now